Uploaded image for project: 'controller'
  1. controller
  2. CONTROLLER-1630

Follower not sync'ing up after rejoining cluster

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Cannot Reproduce
    • Affects Version/s: unspecified
    • Fix Version/s: None
    • Component/s: clustering
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • External issue ID:
      8199

      Description

      I frequently see cases where the follower prints the following after cluster is recovered. It prints it forever and does not seem to recover.

      2017-04-07 11:24:41,471 | INFO | lt-dispatcher-20 | Shard | 187 - org.opendaylight.controller.sal-akka-raft - 1.4.3.Boron-SR3 | member-2-shard-default-operational (Follower): The log is not empty but the prevLogIndex 1685 was not found in it - lastIndex: 1685, snapshotIndex: -1
      2017-04-07 11:24:41,471 | INFO | lt-dispatcher-20 | Shard | 187 - org.opendaylight.controller.sal-akka-raft - 1.4.3.Boron-SR3 | member-2-shard-default-operational (Follower): Follower is out-of-sync so sending negative reply: AppendEntriesReply [term=23, success=false, followerId=member-2-shard-default-operational, logLastIndex=1685, logLastTerm=9, forceInstallSnapshot=false, payloadVersion=5, raftVersion=3]

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            srini.seetharaman@gmail.com Srini Seetharaman
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: