Uploaded image for project: 'netvirt'
  1. netvirt
  2. NETVIRT-1458

Security Group rules dropping IPv6 traffic for any new subnets that are added to the network

    Details

    • Type: Bug
    • Status: In Progress
    • Priority: High
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: aclservice
    • Labels:
      None

      Description

      It's possible there is no connectivity between two VMs on different subnets and different computes, as long as the subnets were created after one of the vms was started.

      Steps to Reproduce:
      1. Create a network, ipv4 subnet and router
      2. Start a VM on this subnet
      3. Create an additional ipv6 subnet on the same network and create another network and subnet with ipv6 and ipv4
      4. Add these 3 new subnets to the router
      5. Start a VM on a different compute
      6. Try to reach the new vm from the old one on ipv6

      Actual results:
      There is no connectivity. Although both vms have ipv6 addresses assigned and connectivity on ipv4 works as expected.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              aswins Aswin Suryanarayanan
              Reporter:
              aswins Aswin Suryanarayanan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: