Uploaded image for project: 'transportpce'
  1. transportpce
  2. TRNSPRTPCE-701

karaf client fails in karaf-4.3.8

    XMLWordPrintable

Details

    • Bug
    • Status: In Progress
    • Highest
    • Resolution: Unresolved
    • Sulfur
    • None
    • tapi
    • None

    Description

      Sulfur-SR3 and Clorine-SR1 are respectively using karaf-4.3.8 and karaf-4.4.2

      In these versions of karaf, when we try to launch the client (./karaf/target/assembly/bin/client), it fails with the following message:

      Logging in as karaf
      DefaultOpenFuture[ChannelShell[id=0, recipient=-1]-ClientSessionImpl[karaf@localhost/127.0.0.1:8101]]: Failed (IllegalArgumentException) to execute: Invalid UINT32 value: -1

      This feature is used in transportpce tapi functional tests to install the odl-transportpce-tapi optional feature.

      Since the tapi feature can no longer be installed, all tapi functional tests are failing on the gate (https://jenkins.opendaylight.org/releng/job/transportpce-tox-verify-sulfur/1372/consoleFull)

      Attachments

        Issue Links

          # Subject Branch Project Status CR V

          Activity

            People

              Unassigned Unassigned
              gthouenon Gilles Thouenon
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated: