Uploaded image for project: 'yangtools'
  1. yangtools
  2. YANGTOOLS-1467

yang-xpath-impl depends on javax.inject

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Medium
    • Resolution: Done
    • 8.0.0, 9.0.0, 10.0.0, 9.0.2, 8.0.8
    • 10.0.1, 9.0.3, 8.0.9
    • xpath
    • None

    Description

      During conversion to bnd-maven-plugin a slight omission was made. Due to how the plugin operates, it ends up generating a mandatory import of javax.inject:

      Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=features-controller; type=karaf.feature; version="[6.0.3,6.0.3]"; filter:="(&(osgi.identity=features-controller)(type=karaf.feature)(version>=6.0.3)(version<=6.0.3))" [caused by: Unable to resolve features-controller/6.0.3: missing requirement [features-controller/6.0.3] osgi.identity; osgi.identity=odl-controller-mdsal-common; type=karaf.feature; version="[6.0.3,6.0.3]" [caused by: Unable to resolve odl-controller-mdsal-common/6.0.3: missing requirement [odl-controller-mdsal-common/6.0.3] osgi.identity; osgi.identity=odl-mdsal-binding-runtime; type=karaf.feature; version="[10.0.0,11.0.0)" [caused by: Unable to resolve odl-mdsal-binding-runtime/10.0.3: missing requirement [odl-mdsal-binding-runtime/10.0.3] osgi.identity; osgi.identity=org.opendaylight.mdsal.binding-dom-codec-osgi; type=osgi.bundle; version="[10.0.3,10.0.3]"; resolution:=mandatory [caused by: Unable to resolve org.opendaylight.mdsal.binding-dom-codec-osgi/10.0.3: missing requirement [org.opendaylight.mdsal.binding-dom-codec-osgi/10.0.3] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.opendaylight.mdsal.dom.schema.osgi)(version>=10.0.0)(!(version>=11.0.0)))" [caused by: Unable to resolve org.opendaylight.mdsal.dom-schema-osgi/10.0.3: missing requirement [org.opendaylight.mdsal.dom-schema-osgi/10.0.3] osgi.service; filter:="(objectClass=org.opendaylight.yangtools.yang.parser.api.YangParserFactory)"; effective:=active [caused by: Unable to resolve org.opendaylight.yangtools.yang-parser-impl/9.0.2: missing requirement [org.opendaylight.yangtools.yang-parser-impl/9.0.2] osgi.service; filter:="(objectClass=org.opendaylight.yangtools.yang.xpath.api.YangXPathParserFactory)"; effective:=active [caused by: Unable to resolve yang-xpath-impl/9.0.2: missing requirement [yang-xpath-impl/9.0.2] osgi.wiring.package; filter:="(osgi.wiring.package=javax.inject)"]]]]]]]

      While usually this requirement is fulfilled through geronimo-atinject-spec or other component installing this, this is not reflected in odl-yangtools-xpath feature.

      Fix this mistake and make javax.inject optional to resolve.

      Attachments

        # Subject Branch Project Status CR V

        Activity

          People

            rovarga Robert Varga
            rovarga Robert Varga
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: